You are here

4 posts / 0 new
Last post
Automator Import Issue #1
bill@billbooth.ca's picture
by bill@billbooth.ca
April 19, 2014 - 3:09pm

I have created an automator script to get JPEGS from a folder on my website. The website folder receives additional files throughout the day. Here is my Workflow:

Synchronize - a folder on my computer with the folder on the website.

Get Specified Finder Items - select the appropriate folder.

Get Folder Contents - grabs the JPEGS

Import Photos -  add the photos to my Aperture Project.

The issue is duplicates. Each time I run the workflow, all the files are added again! Can not seem to make Aperture ignore duplicates, even though the No Dupes box is checked in my project. Any suggestions?

 

As I continue to Google the issue, it would appear that this is a long standing issue.

Bill Booth

Michael Martin's picture
by Michael Martin
April 27, 2014 - 7:25am

You need to tick the option of deleting the images once imported. If you do not want to delete them, add another step to move them to another folder once imported. I guess the problem is that even if you do this, the synchronise part means they will be brought back in again next time, or could be deleted for the web folder. Is it important to keep them in the web folder?

bill@billbooth.ca's picture
by bill@billbooth.ca
April 27, 2014 - 7:35am

Michael,

At this point, I feel the best solution is just a manual import of the files. Hopefully, Aperture 4.? will correct the duplicate issue. Thanks for your interest.

Bill Booth

Michael Martin's picture
by Michael Martin
April 27, 2014 - 7:38am

Hi Bill

Sometimes we try to make it too complex and a manual import, once parameters have been set, takes just a moment anyway, so hardly a big issue. As you say, maybe there will be more functionality in the next version, whenever that might be.

Michael

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?