I've been using the new Canon 1Ds Mk III recently, and as with pretty much any gear I play with, one of the first things I'll do is dig through the preferences/ settings of the kit. After setting up the Mk III as I wanted it, I went out to take my first shots. One thing I noticed right away was that I was only getting two shots off before the buffer was filled! When you look through the viewfinder of this camera (as on most Canon pro cameras), you'll see a display of how many frames you can fire sequentially before the buffer fills and your fps drops below maximum.





Anyway on this 1Ds Mk III I was seeing only two. (I never did switch to JPG to see what I'd get there, as I'm not really interested in JPG shooting on this camera). My first thought was that this was because my CF card wasn't fast enough. Even though my cards are Lexar 2GB 133x cards, they are not UDMA cards. I basically accepted that this was the case (these are 21megapixel files after all), shrugged my shoulders and picked up a UDMA card.










Imagine my surprise when the UDMA card made no difference. So I started looking through the settings, trying to figure out what the problem could be. Digging back into the C Fn's (Custom Functions), I noticed that I had both Long Exposure (C. Fn II-1) and High ISO (C. Fn II-2) noise reduction turned on. I know that the idea behind the long exposure noise reduction is that the camera will process for as long as the exposure was; i.e., a 20 second exposure means a 20 second post-process before it's written to the card. OK.


Just out of interest I turned them both off. And guess what… up shot my continuous exposure count to 12! And in reality, it's more like 15.


This smelled like a bug to me. Because even at ISO 100, if I turn on High ISO reduction, the count drops to 4. Turn it off, it goes back to 12. ISO 100 does not count as high ISO!


Likewise, turn on long exposure noise reduction to "auto" or "on", and it drops to 10 frames in display. This is with a manual exposure set to ISO 100, f/2.8 1/8000th second. Not exactly a long exposure. And it actually stops after 11 shots fired.


So obviously this demanded some research. After some digging, here's the information I came up with. Even though the camera does not utilize the noise reduction at exposures under one second, having it enabled still affects the cameras buffer performance -- and this has been the case in all EOS bodies. The user should not have to turn this on or off if the exposure goes over or under one second, so IMHO this qualifies as a bug.


As far as the High ISO noise reduction, this is a misleading term as when enabled it does process the files differently at ALL ISOs. The higher the ISO the greater the correction, but even at ISO 100 it is handling the files differently to optimize image quality and keep noise to a minimum. This is why the buffer is reduced in this case.


So what's better, let the camera do the noise reduction, or let Aperture do it ('cause that's the software you're using, right?!). If you're shooting RAW, the noise reduction is NOT embedded into the file (thank goodness). Apparently you can alter the embedded reduction settings using Canon's Digital Photo Professional software (never used it myself), or if you're using Aperture (or anything else) to do the RAW decode, that camera data is thrown away and the software does its own thing.


So the short answer is… if you're shooting RAW, turn off the noise filters. If you're shooting JPEG, turn it on. Of course in my not-so-humble opinion, there are only fringe example reasons of why you would shoot JPEG anymore. It's all about the RAW file, baby.


As far as the UDMA / non-UDMA cards are concerned, it turns out that until the buffer is filled you will not see the write speed of the card in action. This will only be visible when the red "writing data" light is on and you see how fast the images are transferred to the card from the buffer. Basically the real question is not how fast you can shoot to the buffer, but how fast can the buffer transfer to the card and clear it for new shots. To test this, just hold down the shutter release on continuous for a set amount of time. In a test of one minute, with my Lexar 133x card I was able to take 64 pictures in one minute; with the Lexar 300x UDMA card I was able to take 77 shots in the one minute. This is a substantial improvement! Of course I think this would be more interesting in a camera like the 1D Mk III, which is all about shooting as many frames per second as possible.


So did I need the UDMA card? For my purposes, no. BUT I now have an 8GB card, which with a 21Mpixel camera is handy!


1 Comment