You are here

3 posts / 0 new
Last post
All Three Built-in Library Recovery Options Don't Work. Now What? #1
Elliott Plack's picture
by Elliott Plack
March 7, 2011 - 10:37am

Joseph,

Firstly, I'm so glad I found the site. I purchased some of your presets and have been happy so far. I need to delve into the audiobooks. I found you by way of TWiP.

Secondly, I'm overseas in Iraq with the military doing (among other things) public affairs work. I have nearly 10,000 pictures documenting this deployment alone, not to mention another 10K or so others from the past few years in the library, and recently it just went kaput. I use Time Machine and Vault (with a Drobo), so I'm not particularly worried about losing the masters, but still, this is becoming quite the hassle…

Situation: I can view, import, and export any picture, but if I try to make an adjustment, edit any of the metadata, use the loupe, or even try to open the HUD, Aperture hangs the entire system. I have to force quit and then it repeats..

I tried all three options that require you to hold Cmd-Opt upon starting but I continue to have the same problem. I've also restarted countless times and cleared out the Aperture preferences file.

What would you recommend I try now? I'd go to a genius bar, but that is impossible currently.

I was thinking about starting a new library and import the old one or something like that. I was also thinking of making smaller libraries for major subjects, like military, cars, etc. How would that work with versions and metadata and stuff?

v/r

Elliott

System: MBP 3,1 | 10.6.6 | Aperture 3.1.1

Elliott Plack's picture
by Elliott Plack
March 7, 2011 - 12:56pm

UPDATE: Solved! (I think)

Joseph and friends, I believe I found a solution for my problem.

(Please note: If you follow this or do any library modifications you should definitely make a backup!!! Time Machine works nicely.)

I decided to completely delete Aperture with AppZapper and re-download. When I saw the plethora of files outside of the Aperture.app that AppZapper located I was surprised! Just to be safe I copied all of the trashed files to a folder on my Drobo. Then I emptied the trash and restarted.

Fingers crossed… I was not able to re-download from the Mac App Store (I purchased an upgrade to a trial key way back when) but the App Store still said Aperture was installed. Fine, Apple, be that way. So I copied back only the Aperture.app from the Drobo back to the applications folder. Knowing a bit how Apple apps work, I figured all the support files would be automatically created.

I was right. Not only did Aperture start up super quick, but all the problems I was having were no longer. That’s why rebuilding the library didn’t do anything for me.

The disadvantage of this approach is that any custom presets and, well, custom anything is lost. I suppose I copy the stuff back to Application Support, but I think I’ll just start all over.

Apple has a KB article that basically tells you to do the same thing. Glad I found this after the fact……. http://support.apple.com/kb/HT3805

Also, you can only lose your serial number/registration if you mess around with Terminal, so worry not.

Cheers!

Elliott

Shameless Plug: Check out my latest work on Flickr, an Iraqi sunrise:
http://www.flickr.com/photos/talllguy/sets/72157626201383284/

PhotoJoseph's picture
by PhotoJoseph
March 7, 2011 - 5:13pm

Elliott,

Thanks for writing in and for following up. I learned something myself—I’d never seen that kb article you pointed to, and didn’t know about holding shift-key to disable preview generation after startup. Interesting! So, thanks for that ;-)

Very interesting how you got it fixed. I liked your suggestion of creating a new library and importing the existing one into that; I’ve fixed issues for myself and other users that way. It’s a great way to reconstruct your library.

Smaller libraries are fine, but do it for convenience, not for performance. I have a fairly large library (140k images) and it hums along just fine.

I downloaded AppZapper so I could see if there was anything I wasn’t aware of that belongs to Aperture, and try to determine which deleted file may have solved your issue. Within the Application Support folders (both system and user) plugins and presets are installed, so you could have had a corruption there. But I’d guess most likely the culprit was the cache.db file in the ~/Library/Caches/com.apple.Aperture folder. That’s a great clean-up tip, and it’s in my ever-growing FAQ list that I keep threatening to write.

The good news is you can probably restore all of your metadata presets without issue. I’d give it a try, personally.

Finally, FYI you can lose your serial number without Terminal, but it’s hard to do. The registration is stored in /Library/Application Support/ProApps/ProAppsSystemID

Great photos of sunrises in Iraq. Good to know there’s some beauty out there.

Best of luck, stay safe, and come home soon.

-Joseph @ApertureExpert

@PhotoJoseph
— Have you signed up for the mailing list?

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness