You are here

4 posts / 0 new
Last post
aperture 3.5.1 - unsupported image format - suddenly #1
iainstatham's picture
by iainstatham
December 16, 2013 - 8:02am

hello, i’m a full-time aperture user - i do everything with aperture and some plugins, everything comes straight off a nikon d4, d800 or a d7000 directly into aperture and i work from there.

suddenly, out of the blue after years of no problems, i’m randomly getting the black background, grey triangle, ‘unsupported image format’ problem at random in my libraries.

images will be there one minute, then suddenly turn to this annoying, useless block - some on images i’ve already begun editing.

i fail to see how this is possible - i rebuilt my library and it seemed to stop happening for a few minutes, now it’s back again.

i’ve done nothing, to change my system - i’m on auto updates so i’m not sure when it upgraded to 3.5.1

i’ve avoided adobe for years, but i see no other choice but having to move to lightroom if i can’t rely on aperture to work properly.

any suggestions??

cheers

iain

Walter Rowe's picture
by Walter Rowe
December 18, 2013 - 7:40am

I had some images do that. Select the affected images and use Photos > Reprocess Original and it should clear that. This forces Aperture to re-read the raw file from disk and regenerate it’s previews and thumbnails.

lugermad's picture
by lugermad
December 20, 2013 - 9:17am

Also I am an aperture expert, I did your suggestion of reprocession, worked for some minutes, worked on some images and again it started to make the error again…

They released an update a couple of days ago, but still doens´t work right..

Michael Walsh's picture
by Michael Walsh
February 16, 2014 - 4:32pm

I heard somewhere (on this site?) in can be caused by a lack of disk space. I moved my Aperture library to a larger disk with more free space, and the issue went away…

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?