You are here

4 posts / 0 new
Last post
Aperture thinks images are duplicates but they do not seem to be in the Aperture library #1
rstreborg's picture
by rstreborg
July 5, 2014 - 1:03pm

In an attempt to clean up my file structure, I’ve been reorganizing my referenced files, using Aperture’s relocate feature. When done I examined the old folders to make sure they were empty. A few had one or two images that apparently had not been moved. I have been unsuccessful in locating these images in Aperture but when I try to import them Aperture will not see them unless I uncheck “Do not import duplicates”. I’m sure these images were imported when I imported the original project. 

Obviously I can uncheck the “Do not import duplicates” feature but I would like to know why it believes they are duplicates and I can not find them and if there is any way to fix the problem.

Any suggestions would be appreciated.

 

streborg

David  Moore's picture
by David Moore
July 6, 2014 - 6:51am

Before importing them can you make a smart album with those names in the text file?  You might have already.  You could change the name of those two file by adding a number or letter  and someday you might find the other two.  A rebuild might help find the problem or fix this inconsistency

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

rstreborg's picture
by rstreborg
July 6, 2014 - 3:32pm

Before posting I did a repair which did not help, followed by a rebuild that did not help.  ”Locate Referenced Files” does not find any errors. Various searches against “Photos” get no hits.

Looking inside the Aperture Library Package I do find small jpg of the missing image under the Thumbnails directory but nothing under the Previews directory.

I’ll think i’ll take your suggestion to change the name of the original image file and import it.  Then I can work on the images. I think creating a permanent smart album that searches for the lost images by name is an interesting idea. That way I’ll know if they every show up.

streborg

David  Moore's picture
by David Moore
July 7, 2014 - 7:08am

I have 4-5 Smart albums  (managed / Referenced, Missing / Offline, Keywords, CopyrightNotice)  and one new one, (1),  This one searches for text that has (1) in the file name and or Version name.  The “(1)” is the indicator that a duplicated file was added to a folder.   Exporting part of a lib to another new library helps rebuild and shake up the DB.  Then rejoining  all parts back into a Newer Lib brings them whole again.  Ive found missing images when I have done this.  Not sure why its more powerful that a repair or rebuild but it is.

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
© 2019 PhotoJoseph.com All rights reserved.