You are here

7 posts / 0 new
Last post
AppleScript: 4-up; Auto Levels & Curves: generates too many duplicates #1
Gert Coester's picture
by Gert Coester
December 27, 2011 - 4:07pm

Hallo there

The script worked after I've changed the language specific commands (I'm Swiss and therefore use German).
BUT: the script generates duplicates and then applies the four presets, which again generates duplicates, since my preferences are set to “generate duplicate after making changes” (don't know the exact wording in the english version …).
So after the script I've three duplicates to many.
What I'd love to get its one original and four duplicates with the corresponding presets.

How could that be done ?

Thanks very much !
Gert Coester

GC

Morten Scheel's picture
by Morten Scheel
January 2, 2012 - 11:52am

Hi Gert and happy new year.

Thanks for pointing out a problem with the script. I’ve tried everything I know, but I can’t find a solution that works. I tried applying the 4 presets to the same image, but it only generated one copy. I tried deleting the unnecessary versions at the end of the script, but could only delete the adjusted versions.
So… I am really sorry but I can’t help you there. It looks like you’ll have to manually delete the extra versions yourself.

Morten

Gert Coester's picture
by Gert Coester
January 2, 2012 - 12:03pm

Hi Morten
Thanks for trying all this!
But since a script does automize what one types in manually, I don’t understand, why applying the presets to one image doesn’t work - manually it does !? Have you set the corresponding preference to “making a copy after applying changes” ? Sorry for asking such a basic question, but sometimes this can happen to professionals too …
Cheers
Gert

GC

Morten Scheel's picture
by Morten Scheel
January 2, 2012 - 12:14pm

That’s okay, it took a while for me to understand what happened. And yes, I’m making copies after applying changes.
I’ll do my best to explain what happens: The script stores a reference to the originally selected photo. Then a preset is applied and a new copy is generated. So far so good. But for some reason the original reference now points to the image that has been adjusted. And if I keep applying presets to that one, it doesn’t make new copies but just puts one on top of the other.

I also tried deleting the unnecessary versions afterwards. But unfortunately I can’t get Aperture to give me their references. The copy that Aperture makes when you make an adjustment comes out of the blue and there’s no way to access it from a script.

Gert Coester's picture
by Gert Coester
January 2, 2012 - 12:18pm

Well, then nothing can be done there and I will delete the copies I don’t need.
Thanks again and happy new year to you too :-))

GC

PhotoJoseph's picture
by PhotoJoseph
January 2, 2012 - 9:52pm

Thanks for trying to help Morten.

Gert, I suppose then the options are to either delete them manually, or just disable that “Create new versions when making adjustments” feature in the Preferences. Personally, on rare occasions that I do want to keep the original behind, I’ll just hit the Option-V command to Duplicate Version before adjusting.

Sorry we can’t be more helpful :(

@PhotoJoseph
— Have you signed up for the mailing list?

Gwyneth Smith's picture
by Gwyneth Smith
February 3, 2012 - 7:37am

Talk about Apple in here, I read in an article that many longtime customers of Apple’s Final Cut Pro non-linear video editing software were upset when the business upgraded to Final Cut Pro X last summer. The software has been a staple for video editors, pro and novice, since 1998. But the new edition is incompatible with files from old versions of the software, and the interface has been completely redesigned. Apple released upgrade 10.0.3 Tues in an attempt to correct some of the problems. Source for this article: New update for FCP X addresses user complaints

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness