You are here

5 posts / 0 new
Last post
"Calculate Storage Space" - does this still work? #1
Klaus T's picture
by Klaus T
January 23, 2013 - 5:07pm

Hi guys,

Is anyone else able to get “Calculate Storage Space v1.0” to work with the current version of Aperture and Mountain Lion?

I don't use it so much, but sometimes it's nice to see how much a selection takes up of disk space, but this time it doesn't popup and gives me the result.

“Convert Master File Format v 1.0” does seem to work though, it pops up like it usually does.

Thought maybe something has changed, making the Calculate Storage Space thingy no longer work?

Tom Thomson's picture
by Tom Thomson
January 23, 2013 - 8:50pm

It’s worked well for me recently, but I’m afraid I don’t know what to suggest.
Good luck,
Tom

Tom Thomson

Klaus T's picture
by Klaus T
January 23, 2013 - 10:20pm

I’m glad it still works for you, Tom :) Unfortunately I can’t say the same for mine. I tried to restart my Mac, but no changes.

Console reports this error though:

AppleScript Runner[369]: CPSGetFrontProcess(): This call is deprecated and should not be called anymore.

That error does not show up when running the “Convert Master File Format” script, only when using the “Calculate Storage Space” script - and then in return, I get no popup with the result.

Klaus T's picture
by Klaus T
February 7, 2013 - 10:05pm

Thought I would try to bump this one, hoping that somebody might have any ideas? :)

Klaus T's picture
by Klaus T
February 7, 2013 - 10:28pm

Oh what do you know, I fixed it myself :)

(and sorry for posting this thread in the wrong forum, by the way).

What I did: I have all 3 AppleScripts (Calculate Storage Space, Convert Master File Format, Open Master in Lightroom). I noticed that the two later ones (which works) were last edited years ago, but the Calculate Storage Space was edited just a few months ago - and AppleScript Editor wouldn’t even open it.

So Time Machine to the rescue - went back to November and pulled out a version that was 9kb in size, compared to the version I currently had, which was 28kb.

AND IT WORKS!

So apparently, sometime in the middle of December, something messed up that AppleSCript size, making it 3x its size and caused it to no longer work… weird! But now I’ve “locked” all 3 files, so hopefully it doesn’t happen again.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness