You are here

2 posts / 0 new
Last post
Help with beachballing in Aperture - Console error message #1
Matthew London's picture
by Matthew London
November 29, 2013 - 4:14pm

Hi,

Running Aperture 3.4.5 on OS 10.8.5 on a MacPro 2008
(no, please do not suggest updating to 3.5.x & 10.9 - I’m on a hard production and cannot afford additional workflow disruptions)

I’ve recently been getting alot of beachballing in Aperture. The machine is pretty clean with respect to other software, so I’m thinking it might have something to do with the 10.8.5 update.

The console is reporting the following error messages:
11/26/13 2:04:47.561 PM WindowServer[136]: CGXDisableUpdate: UI updates were forcibly disabled by application “Aperture” for over 1.00 seconds. Server has re-enabled them.
11/26/13 2:05:01.562 PM WindowServer[136]: disable_update_likely_unbalanced: UI updates still disabled by application “Aperture” after 15.00 seconds (server forcibly re-enabled them after 1.00 seconds). Likely an unbalanced disableUpdate call.
11/26/13 2:05:53.701 PM WindowServer[136]: reenable_update_for_connection: UI updates were finally reenabled by application “Aperture” after 67.14 seconds (server forcibly re-enabled them after 1.00 seconds)

I’ve run EtreCheck, but it does not report any failed LaunchDaemons/LaunchAgents.

I tried creating a new user account, but still have the problem, so it must be something at System leve. I tried SafeBoot, but Aperture reported that the GraphicsCard was unsupported (in SafeBoot mode), so unable to test further with SafeBoot.

Also re-ran the 10.8.5 Combo Updater, but that did not help.

I’m using a ATI AMD Radeon 6970 Graphics card which was purchased from someone who flashes them for use on the MacPro and it has been 100% reliable. I checked with the vendor and there are no updates/firmware issues, etc. and it is only happening with Aperture, so unlikely anything to do with the graphics card.

Any suggestions are highly appreciated.
Thank you

Matthew

"There is nothing worse than a sharp photograph of a fuzzy concept." Ansel Adams

Andrew Mumford's picture
by Andrew Mumford
November 29, 2013 - 7:54pm

Have you installed any custom graphics drivers from AMD or any other custom extensions that have to do with the GPU or Open / CL ?

Also searching the web for CGX update turned up a ton of suggestions none of which were Aperture specific - I would suggest maybe the error msg is a red herring unless it’s appearance in the log is entirely coincedent in time with the beach balling - try working with the console open and check the log every time it beach balls …

 

 

---
Andrew Mumford

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness