You are here

4 posts / 0 new
Last post
Managed files found creating Vault, updating Vault hangs #1
redpine's picture
by redpine
August 29, 2014 - 8:57am

I have not used vaults up to now. Upon creating the first one I saw a message that I had “xxx managed files and xxxxx referenced files”. This surprised me since I am careful to only use referenced. Searching my library for managed shows 0 results.

 

But I went ahead & created it. Upon trying to update it, I see progress for a while & the Aperture hangs. After a force quit attempting to update the vault hangs again.

 

Does anyone know why Aperture thinks I have managed files? Is this likely to be causing the update to hang? Or are vaults just flakey? Thanks.

David  Moore's picture
by David Moore
August 30, 2014 - 1:21pm

Try to let the Vault run 24-48 hours.  It looks like it has stopped but it hasn’t.  If it still trying after 48 hours and you have to shut down then do so.  Hold the option + command keys when starting AP.  Do all three maintenance steps in order, you will need your password for the first one.  Some where you have a mixed up Lib.  Building Smart albums is good to find referenced, Managed, offline, Missing,  copyright notice, etc.  Fix all offline and Missing images and then do the above maintenance step again. Then the smart albums till every things ok.   I found problems by doing a search for images that were “0” mb in size.  

 

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

redpine's picture
by redpine
August 30, 2014 - 4:48pm

Thanks.

I did the first two steps (rebuilding the database seem drastic) and updated my vault. It still says I have managed files. But it did complete on it’s own.

A smart folder looking for managed files does not find any. Nothing offline or missing either.

Are you suggesting I search my filesystem (where the referenced files are) for 0 size files? Is rebuilding the database as scary as it sounds?

Before I decided I needed a Vault I didn’t know I had this problem. Now I’m determined to understand what’s going on. Thanks again.

David  Moore's picture
by David Moore
August 31, 2014 - 8:56am

Hi 

My example was just a weird example of how a data base can get messed up.  Get to know Smart album and use it cuz sometime it will make an album that you don’t understand how it came up with the results.  

Ive rebuilt my lib probably 30-40 times …. sometimes it got worse…. but Its the best its been in years now.  One reason people stop using Vaults is cause it does make you aware of possible problems.   You could just keep a copy of the lib on another HD and call it good.  My mess was cause in the early days I  screwed up moving things around and then tried to fix it with another error method.  Also had Hard drive that failed, power outages in the middle of working on the lib, etc…..     I had duplicates of images that the finder added  a (1) to the name  or sometimes  I had five of them.  Did a smart album for names that include (1) in the data;  also had some in the Version Name that way.  My biggest problem that corrupted the lib was adding Layer masks in Photoshop before importing them into AP.  But I love the program.  cheers

 

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?
randomness