You are here

7 posts / 0 new
Last post
Modify "Auto Enhance" behavior #1
Dave W's picture
by Dave W
August 12, 2012 - 7:08pm

I have tried to find this but my Google-fu appears to have failed me.

Is there a way to modify the auto-enhance functions? I want to add auto white balance and RGB curves to the set.

Thanks for the info.

Dave

PhotoJoseph's picture
by PhotoJoseph
August 13, 2012 - 9:07pm

Dave,

This is my understanding of Auto Enhance, although to be fair I haven’t dug into this to really test this all out.

The Auto Enhance button runs the “Auto Enhance” Effect, located under Quick Fixes > Auto Enhance [screenshot]. This includes:

• White Balance
• Exposure
• Enhance
• Curves
• Highlights & Shadows

It’s important to note however that Aperture will apply only the effects it determines are needed — you will find that some effects are not applied to some images. This is what makes the Auto button so powerful.

If you wanted to add or remove something from the list, I’m 99% sure you can just duplicate that preset, and modify the preset. It may even just run the first command in the list; I’m not sure if it needs to be called Auto Enhance (although I’d guess it does).

Experiment and let us know what you find!

@PhotoJoseph
— Have you signed up for the mailing list?

Dave W's picture
by Dave W
August 13, 2012 - 9:15pm

This is exactly what I was looking for!
I have been playing with it the last hour or so and noticed that it does selectively apply the items in the above mentioned preset. This is what was throwing me. The fact that sometimes it would apply it and sometimes not. *Ding* the light comes on. Will now proceed to make my own Auto preset that works with my needs.

Thanks for the help. Once again your site helped when the rest of the net failed.

Kenny Poulsen's picture
by Kenny Poulsen
August 12, 2012 - 9:36pm

But…both are already included ….?

Dave W's picture
by Dave W
August 12, 2012 - 9:47pm

Let me clarify.

I want Aperture to automatically (automagically) perform “auto WB” and “auto RGB curves” when I hit the magic wand button for Auto Enhance. It does not currently do that. At least in my set up.

OS X 10.8, Aperture 3.3

Thanks,
Dave

Kenny Poulsen's picture
by Kenny Poulsen
August 13, 2012 - 5:33am

I just checked, wb is adjusted so are curves. Seems that curves is auto b/w, i think which i prefer for 95% of shots.

Dave W's picture
by Dave W
August 13, 2012 - 2:31pm

Thanks all.

I will have to experiment and see if I am just not noticing the edits. There does deem to be a change when I hit the magic wand, click auto curves, and then auto WB. Will do some comparisons today and post my findings.

Thanks again for the replies.

Dave

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?