You are here

15 posts / 0 new
Last post
Nik Collection plug-ins don't work after upgrade to Yosemite #1
Lutz Braum's picture
by Lutz Braum
October 18, 2014 - 12:15pm

I just upgraded to Yosemite (on Mac Pro), and when I try to use Nik plugins, I get a message telling me that my ‘trial has expired’. When I input the codes that are on the CD I purchased, I only get error codes. I tried uninstalling so I could re-install, but after uninstalling, the CD doesn’t give me the option to install, the only option is ‘uninstall’ - even though I just did that. Any ideas on how to get my plug-ins back?

Florian Cortese's picture
by Florian Cortese
October 18, 2014 - 5:38pm

You probably need to contact Apple support or Apple Care to see if they can help you.  If not then you may have to contact Google and see if they can help you out  My NIK Complete was downloaded to my HD so I don’t have a CD.  Curious to see if anyone else has this problem with NIK or any other plugin.  I’ve read on line that PS CC works fine and Macphun has already said that they will have an extension for Photos.app ready by winter in anticipation of the Photos.app release in early 2015 so I would assume that that should work.  Let us know what happens.  Good luck.

Florian Cortese
www.fotosbyflorian.com

Thomas Emmerich's picture
by Thomas Emmerich
October 19, 2014 - 10:04pm

If you have a CD then you bought from the original Nik corporation. They were subsequently bought out by Google. If you own at least one Nik product, you can now get the entire suite from Google for no extra charge.

Assuming you registered your Nik SW, you should have received an email with instructions for downloading the entire Nik suite from Google. If you didn’t get that email, I suggest starting on this Nik help page.

Thomas

Scott Thomas's picture
by Scott Thomas
October 20, 2014 - 12:26pm

Note to self (and others), find all your authorization codes for ALL third party software and plugin vendors before upgrading.  Also, make sure they work on Yosemite before, too.

Charles Putnam's picture
by Charles Putnam
October 21, 2014 - 10:32am

I emailed NikGoogle asking about Yosemite compatibility.  Got the usual canned response of “not yet”.  Their compatibility page will be updated when it is.

So….Yosemite was released in June to developers - what the heck has NikGoogle been doing since then?  

Jonathan Tee's picture
by Jonathan Tee
October 27, 2014 - 11:55am

I have the same problem, all nik plugins say “trial has expired”

Joseph Samuels's picture
by Joseph Samuels
October 28, 2014 - 2:37am

I have Yosemite and Aperture 3.6 and my Nik plug-ins work like a charm.  I used them extensively after a photo shoot on Sunday.

jsamu50901

Dai Martin's picture
by Dai Martin
October 28, 2014 - 5:26am

Ditto with Yosemite and Aperture 3.6 with NIK plugins (downloaded - not from CD) all working as superbly as before (better actually with 3.6 which seems much snappier?)

helalwi's picture
by helalwi
November 1, 2014 - 5:07pm

my define2 has disappeared after upgrading Aperture/Yosemite. But I had a backup of the download file “Dfine2-pal-ver2.111all.dmg” that I took for a new installation. The key i had on an old mail. That key worked fine and define2 is working perfectly now with the new Aperture Release.

Still i wonder why i got no mail from Google … . I would be interested in getting the whole suit at no additional charge.

Best regards, Alex

Dai Martin's picture
by Dai Martin
November 2, 2014 - 2:16am

It looks like you are running old versions? (My version of Define is on 2.2.16)

You can download the lot as detailed below from NIK.

“To update your software manually, please download the latest version of the Nik Collection from Google.com/NikCollection. If you previously had a registered version of the Nik Collection installed on your computer, downloading installing the trial from the homepage will simply update the files for you. Make sure that all host applications are closed, run the installer, and your plug-ins will be back in place once you re-open the host”

Florian Cortese's picture
by Florian Cortese
November 9, 2014 - 7:38am

My new rMBP computer arrived already loaded with Yosemite.  I did a time Machine transfer of my stuff off of my older MBP to the new one, then did the Aperture 3.6 upgrade and everything seems to be working fine.  The Nik collection plug ins work, so does PS CC. I have to get my activation codes for some macphun plugins (can’t seem to locate the original emails so I’v emailed macphun.  Also, no apparent WiFi issues that have plagued others who upgraded to Yosemite.  Apple does have a 10.10.1 beta out being tested that is specifically addressing issues with wifi and notification center, so hopefully, that upgrade will be released soon. Fingers crossed and hopes that the new upgrade will solve these problems for others.

Florian Cortese
www.fotosbyflorian.com

Mike Hughes's picture
by Mike Hughes
November 11, 2014 - 8:29am

I too have bought a new Mac and built it up with a Time Machine Backup, loaded Aperture 3.6 but Nik Collection doesn’t work. I have now just downloaded new version of Nik Collection as described by Dai Martin above … guess what, it still doesn’t work!!!!!!!!!

Stuart's picture
by Stuart
November 13, 2014 - 8:48am

I had some issues with Nik along with Aperture after installing Yosimite. Did a repair data base and everything started working well.

Jim Burgess's picture
by Jim Burgess
November 13, 2014 - 5:57pm

There’s a new release that includes “official” support for Yosemite. See it here:

https://support.google.com/nikcollection/answer/4400822?hl=en&ref_topic=3001406

or here:

Nik Collection by Google

Lutz Braum's picture
by Lutz Braum
November 13, 2014 - 7:39pm

Thanks everyone for your input. I downloaded the apps again and installed them again, and now it works. Seems that this worked.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?