You are here

5 posts / 0 new
Last post
Where do pre-2010 masters live in the package? #1
David Edge's picture
by David Edge
August 29, 2014 - 4:32am

I’ve done “View Package Contents” and under masters there are directories for 2010, 2011 … 2014 - but not for earlier images. I can relocate them and they do exist and then consolidate them - but I’m curious as to where they live!

d.

David  Moore's picture
by David Moore
August 30, 2014 - 1:28pm

When you relocate originals you choice a folder for them to be stored in.  I’m concerned by your statement they do not exist.   Are these images showing an offline or missing symbol on the thumbnail?  A Smart album indicating Referenced and Managed may  help to determine where they are.  Let us know if that helps you and ask more questions when you get there.

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

David Edge's picture
by David Edge
August 31, 2014 - 11:48am

Thanks David

I’ve been a bit too cryptic. I’ll try and explain more carefully!

I’ve recently converted my library back to managed so that if and when I move to LR I will export to the project directories, not the daily ones, but that’s by the by.

So I needed to restore a 2014 file so went to “Show Package Contents” and found the Masters folder and 2010…2014 folders below that plus also a “Users” folder where videos live. The year folders have month and day folders as you’d expect. This is Managed photos in the package. No sign of the pre-2010 masters. They are in there because:

- there are only two referenced images in the library

- there is only one offline image in the library

- I can edit pre-2010 images

- I can relocate the masters and then reconsolidate them back

But I just can’t see them in the package contents and so if I ever needed to restore one from Time Machine would have a problem finding the folder to restore.

d.

David  Moore's picture
by David Moore
August 31, 2014 - 4:26pm

I checked my Lib by opening up the Package, Show Package Contents.  My thumbnail images have the same years 2007-2014 as the Preview folder.  My masters folder is basically empty since all but one image is Referenced.  Because you are Managed your Master folder should have the same years as your Thumbnails folder, and previews folder  if you store them.

Weird

I would export your Pre-2010 as originals not versions to a good back up folder.  That will duplicate them to a new folder for safe keeping.  Have you run the three step Maintenance  Option Command when opening ?  Do you Have other lib on your HD

Do all the maintenance especially the Rebuild and let me know.  The only things that come to mind is a corrupted Lib.   One other trick is to export Pre-2010 as a separate Lib and include the masters.  Open that good lib and see if things are working as expected.  If all is good Delete pre2010 from the” problem lib” and re-import the good lib so that you are at full circle, one whole lib.  Please make the dup folder of the  ”export Original Files”, (2nd  paragraph above), before exporting the Pre 2010 as a Library.  Hope that made sense!!!!!!  

Somebody said, In time all shall be revealed”   cheers

davidbmoore@mac.com
Twitter= @davidbmoore
Scottsdale AZ

David Edge's picture
by David Edge
September 3, 2014 - 2:02pm

Well I did all three types of maintenance and none changed things. Only 2010-2014 directories in Masters, Previews and Thumbnails.

I’ve decided to be pragmatic - my intention in consolidating was to export to a project folder structure rather than a yyyy mm dd structure which is a mess for scans of old photos where I really only know the year.

So rather than fiddle any further I’ve simply relocated the masters back out and they’re ending up where I want them to be so I think I’ll say case closed. As an old IT guy I’d love to know what’s going on - as I suspect do you - but I know from bitter experience that the Aperture database can be curmudgeonly on its good days!

cheers

d.

d.

You may login with either your assigned username or your e-mail address.
Passwords are case-sensitive - Forgot your password?